<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Bacon goes way beyond mealtime - Empire Press | Empire Press</title>

<link rel="stylesheet" href="https://empire-press.com/wp-content/themes/SimplePress/style.css" type="text/css" media="screen" />
<link rel="stylesheet" href="https://empire-press.com/wp-content/themes/SimplePress/css/jquery.fancybox-1.2.6.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="Empire Press RSS Feed" href="https://empire-press.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="Empire Press Atom Feed" href="https://empire-press.com/feed/atom/" />
<link rel="pingback" href="https://empire-press.com/xmlrpc.php" />

<!-- This site is optimized with the Yoast SEO plugin v9.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://empire-press.com/2019/01/bacon-goes-way-beyond-mealtime/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Bacon goes way beyond mealtime - Empire Press" />
<meta property="og:description" content="There’s a saying: “Everything’s better with bacon.” And it’s true. Bacon is greasy and crunchy. It’s chewy and salty. It’s delectable and balanced. Bacon is akin to nature’s perfect food." />
<meta property="og:url" content="https://empire-press.com/2019/01/bacon-goes-way-beyond-mealtime/" />
<meta property="og:site_name" content="Empire Press" />
<meta property="article:publisher" content="https://www.facebook.com/Empire.Press/?ref=mf" />
<meta property="article:section" content="All Content" />
<meta property="article:published_time" content="2019-01-25T06:06:33+00:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="There’s a saying: “Everything’s better with bacon.” And it’s true. Bacon is greasy and crunchy. It’s chewy and salty. It’s delectable and balanced. Bacon is akin to nature’s perfect food." />
<meta name="twitter:title" content="Bacon goes way beyond mealtime - Empire Press" />
<meta name="twitter:site" content="@DCEmpirePress" />
<meta name="twitter:image" content="http://empire-press.com/wp-content/uploads/2016/09/empirepress_small.jpg" />
<meta name="twitter:creator" content="@DCEmpirePress" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/empire-press.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="SimplePress v.1.5" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<script type='text/javascript' src='https://empire-press.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://empire-press.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://empire-press.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://empire-press.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://empire-press.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://empire-press.com/?p=28469' />
<link rel="alternate" type="application/json+oembed" href="https://empire-press.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fempire-press.com%2F2019%2F01%2Fbacon-goes-way-beyond-mealtime%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://empire-press.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fempire-press.com%2F2019%2F01%2Fbacon-goes-way-beyond-mealtime%2F&#038;format=xml" />
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
#content p {
	font-size: 14px;
}

div.alignleft {
	float: left;
	margin: 20px 10px 0 0;
}

div.alignright {
	float: right;
	margin: 20px 0 0 10px;
}

.aligncenter {
    margin: 0 auto;
    display: block;
}

.post ul {
    list-style: inside;
    margin: 10px;
    font-size: 14px;
}		</style>
	<!--[if lt IE 7]>
    <link rel="stylesheet" type="text/css" href="https://empire-press.com/wp-content/themes/SimplePress/css/ie6style.css" />
    <script type="text/javascript" src="https://empire-press.com/wp-content/themes/SimplePress/js/DD_belatedPNG_0.0.8a-min.js"></script>
    <script type="text/javascript">DD_belatedPNG.fix('img#logo, .slider_image img, .banner, .banner .readmore, .wrap .image img, .thumb div .image img, div.avatar span.overlay');</script>
<![endif]--> 
<!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="https://empire-press.com/wp-content/themes/SimplePress/css/ie7style.css" />
<![endif]--> 
<script src="https://empire-press.com/wp-content/themes/SimplePress/js/fancybox.js" type="text/javascript"></script> 
<script src="https://empire-press.com/wp-content/themes/SimplePress/js/easing.js" type="text/javascript"></script> 
<script src="https://empire-press.com/wp-content/themes/SimplePress/js/cufon-yui.js" type="text/javascript"></script> 
<script src="https://empire-press.com/wp-content/themes/SimplePress/js/superfish.js" type="text/javascript"></script> 
</head>
<body>
<div class="wrapper">

  <a href="https://empire-press.com"><img src="https://empire-press.com/wp-content/themes/SimplePress/images/logo.png" alt="logo" id="logo" /></a>
    
    <div id="navwrap">
        <span class="nav_top"></span>
		            <ul class="nav superfish">
                                
                <li class="page_item page-item-97 current_page_parent"><a href="https://empire-press.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-1911"><a href="https://empire-press.com/legals/">Legals</a></li>
<li class="page_item page-item-222"><a href="https://empire-press.com/terms-of-use/">Terms of use</a></li>
                	<li class="cat-item cat-item-5"><a href="https://empire-press.com/category/news/" title="All editorial content in Empire Press">All Content</a>
</li>
	<li class="cat-item cat-item-210"><a href="https://empire-press.com/category/communities/" title="Stories from various communities covered by Empire Press">Communities</a>
<ul class='children'>
	<li class="cat-item cat-item-214"><a href="https://empire-press.com/category/communities/brewster/" title="Stories from in and around Brewster">Brewster</a>
</li>
	<li class="cat-item cat-item-213"><a href="https://empire-press.com/category/communities/bridgeport/" title="Stories from in and around Bridgeport">Bridgeport</a>
</li>
	<li class="cat-item cat-item-216"><a href="https://empire-press.com/category/communities/douglas-communities/" title="Stories from in and around Douglas">Douglas</a>
</li>
	<li class="cat-item cat-item-219"><a href="https://empire-press.com/category/communities/eastwenatchee/" title="Stories from in and around East Wenatchee">East Wenatchee</a>
</li>
	<li class="cat-item cat-item-325"><a href="https://empire-press.com/category/communities/farmer/" title="Stories from in and around Farmer">Farmer</a>
</li>
	<li class="cat-item cat-item-215"><a href="https://empire-press.com/category/communities/mansfield/" title="Stories from in and around Mansfield">Mansfield</a>
</li>
	<li class="cat-item cat-item-212"><a href="https://empire-press.com/category/communities/orondo/" title="Stories from in and around Orondo">Orondo</a>
</li>
	<li class="cat-item cat-item-250"><a href="https://empire-press.com/category/communities/wenatchee-communities/" title="Stories from Wenatchee and other outlying communities">Other Communities</a>
</li>
	<li class="cat-item cat-item-217"><a href="https://empire-press.com/category/communities/palisades/" title="Stories from in and around Palisades">Palisades</a>
</li>
	<li class="cat-item cat-item-211"><a href="https://empire-press.com/category/communities/rockisland/" title="Stories from in and around Rock Island">Rock Island</a>
</li>
	<li class="cat-item cat-item-169"><a href="https://empire-press.com/category/communities/waterville/" title="Stories from in and around Waterville">Waterville</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-335"><a href="https://empire-press.com/category/correspondents/" title="Stories by Empire Press correspondents">Correspondents</a>
<ul class='children'>
	<li class="cat-item cat-item-336"><a href="https://empire-press.com/category/correspondents/adrienne-douke/" title="Stories written by Empire Press correspondent Adrienne Douke">Adrienne Douke</a>
</li>
	<li class="cat-item cat-item-339"><a href="https://empire-press.com/category/correspondents/darlene-paterson/" title="Stories written by Empire Press correspondent Darlene Paterson">Darlene Paterson</a>
</li>
	<li class="cat-item cat-item-368"><a href="https://empire-press.com/category/correspondents/david-heiling/" >David Heiling</a>
</li>
	<li class="cat-item cat-item-340"><a href="https://empire-press.com/category/correspondents/james-robinson/" title="Stories written by Empire Press correspondent James Robinson">James Robinson</a>
</li>
	<li class="cat-item cat-item-337"><a href="https://empire-press.com/category/correspondents/karen-larsen/" title="Stories written by Empire Press correspondent Karen Larsen">Karen Larsen</a>
</li>
	<li class="cat-item cat-item-341"><a href="https://empire-press.com/category/correspondents/suzanne-robinson/" title="Stories written by Empire Press correspondent Suzanne Robinson">Suzanne Robinson</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-326"><a href="https://empire-press.com/category/news-2/" title="Stories by subject from various communities covered by Empire Press">News</a>
<ul class='children'>
	<li class="cat-item cat-item-327"><a href="https://empire-press.com/category/news-2/business/" title="Stories about agriculture and businesses from various communities covered by Empire Press">Agriculture &amp; Business</a>
</li>
	<li class="cat-item cat-item-318"><a href="https://empire-press.com/category/news-2/obituaries/" title="Death Notices that have appeared in the Empire Press.">Death Notices</a>
</li>
	<li class="cat-item cat-item-330"><a href="https://empire-press.com/category/news-2/elections/" title="Stories about campaigning and elections from various communities covered by Empire Press">Elections</a>
</li>
	<li class="cat-item cat-item-331"><a href="https://empire-press.com/category/news-2/entertainment/" title="Stories about arts and entertainment from various communities covered by Empire Press">Entertainment</a>
</li>
	<li class="cat-item cat-item-332"><a href="https://empire-press.com/category/news-2/features/" title="Feature stories from various communities covered by Empire Press">Features</a>
</li>
	<li class="cat-item cat-item-333"><a href="https://empire-press.com/category/news-2/food-religion/" title="Stories about food, recipes and churches from various communities covered by Empire Press">Food &amp; Religion</a>
</li>
	<li class="cat-item cat-item-221"><a href="https://empire-press.com/category/news-2/towncouncil/" title="Stories about government from various communities covered by Empire Press">Government</a>
</li>
	<li class="cat-item cat-item-370"><a href="https://empire-press.com/category/news-2/health/" >Health and Medicine</a>
</li>
	<li class="cat-item cat-item-369"><a href="https://empire-press.com/category/news-2/marriage-licenses/" >Marriage Licenses</a>
</li>
	<li class="cat-item cat-item-334"><a href="https://empire-press.com/category/news-2/recreation/" title="Stories about recreation from various communities covered by Empire Press">Recreation</a>
</li>
	<li class="cat-item cat-item-328"><a href="https://empire-press.com/category/news-2/schools/" title="Stories about schools and education from various communities covered by Empire Press">Schools</a>
</li>
	<li class="cat-item cat-item-366"><a href="https://empire-press.com/category/news-2/sheriffs-report/" title="Incident reported by the Douglas County Sheriff&#039;s Office">Sheriff&#039;s Report</a>
</li>
	<li class="cat-item cat-item-362"><a href="https://empire-press.com/category/news-2/washington-news-service/" title="Washington News Service is a part of the Public News Service, an independent member-supported national news service based in Boulder, Colo., that distributes public interest news and information.">Washington News Service</a>
</li>
	<li class="cat-item cat-item-364"><a href="https://empire-press.com/category/news-2/washington-newspaper-publishers-assoc/" title="Stories provided through a reporting internship sponsored by the Washington Newspaper Publishers Association Foundation.">Washington Newspaper Publishers Assoc.</a>
</li>
	<li class="cat-item cat-item-365"><a href="https://empire-press.com/category/news-2/washington-state-university-news-services/" title="Stories provided from WSU News.">Washington State University News Services</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-343"><a href="https://empire-press.com/category/special/" title="Special events, occasions and features from various communities covered by Empire Press">Special</a>
<ul class='children'>
	<li class="cat-item cat-item-344"><a href="https://empire-press.com/category/special/barn-quilts-of-douglas-county/" title="Stories about the Barn Quilts of Douglas County project">Barn Quilts of Douglas County</a>
</li>
	<li class="cat-item cat-item-363"><a href="https://empire-press.com/category/special/community-calendar/" title="Your connection to events happening in the Empire Press circulation area">Community Calendar</a>
</li>
	<li class="cat-item cat-item-345"><a href="https://empire-press.com/category/special/crab-feed-auction/" title="Stories about the NCW Fair&#039;s Crab Feed &amp; Auction fundraiser">Crab Feed &amp; Auction</a>
</li>
	<li class="cat-item cat-item-347"><a href="https://empire-press.com/category/special/graduation/" title="Stories about graduation ceremonies from various communities covered by Empire Press">Graduation</a>
</li>
	<li class="cat-item cat-item-353"><a href="https://empire-press.com/category/special/history-2/" title="Stories and columns about the history of Waterville and Douglas County">History</a>
	<ul class='children'>
	<li class="cat-item cat-item-199"><a href="https://empire-press.com/category/special/history-2/news-from-our-past/" title="Douglas County news from 100, 50, 25 and 10 years ago">News from Our Past</a>
</li>
	<li class="cat-item cat-item-186"><a href="https://empire-press.com/category/special/history-2/history/" title="Empire Press correspondent Karen Larsen writes about Waterville history">Our Past</a>
</li>
	<li class="cat-item cat-item-354"><a href="https://empire-press.com/category/special/history-2/pictorial-past/" title="Photos from Douglas County&#039;s past">Pictorial Past</a>
</li>
	</ul>
</li>
	<li class="cat-item cat-item-348"><a href="https://empire-press.com/category/special/holidays/" title="Stories about holiday celebrations and observances from various communities covered by Empire Press">Holidays</a>
</li>
	<li class="cat-item cat-item-315"><a href="https://empire-press.com/category/special/leadership-day/" title="Stories about Waterville School&#039;s Leadership Day, a showcase of student achievement">Leadership Day</a>
</li>
	<li class="cat-item cat-item-324"><a href="https://empire-press.com/category/special/ncw-community-success-summit/" >NCW Community Success Summit</a>
</li>
	<li class="cat-item cat-item-316"><a href="https://empire-press.com/category/special/ncw-district-fair/" title="Stories about fair activities and events">NCW Fair</a>
</li>
	<li class="cat-item cat-item-314"><a href="https://empire-press.com/category/special/on-main-street/" title="An occasional column featuring snippets of business news from Waterville and other Doug County communities">On Main Street</a>
</li>
	<li class="cat-item cat-item-361"><a href="https://empire-press.com/category/special/pet-of-the-week/" title="Featured Pet of the Week, provided by the Wenatchee Valley Humane Society">Pet of the Week</a>
</li>
	<li class="cat-item cat-item-182"><a href="https://empire-press.com/category/special/voices/" title="Editorials, commentary and contributing writer stories">Voices</a>
	<ul class='children'>
	<li class="cat-item cat-item-359"><a href="https://empire-press.com/category/special/voices/center-for-rural-affairs/" title="Column written by the staff of the Center for Rural Affairs, a private, nonprofit organization, based in Lyons, Neb., working to strengthen small businesses, family farms and ranches, and rural communities through action-oriented programs addressing social, economic and environmental issues.">Center for Rural Affairs</a>
</li>
	<li class="cat-item cat-item-360"><a href="https://empire-press.com/category/special/voices/contributing-writers/" title="Columns written by various contributing writers in Douglas County communities.">Contributing Writers</a>
</li>
	<li class="cat-item cat-item-357"><a href="https://empire-press.com/category/special/voices/don-brunell/" title="Column written by Don Brunell, a business analyst, writer and columnist. He retired as president of the Association of Washington Business.">Don Brunell</a>
</li>
	<li class="cat-item cat-item-367"><a href="https://empire-press.com/category/special/voices/jill-pertler/" title="Slices of Life">Jill Pertler</a>
</li>
	<li class="cat-item cat-item-183"><a href="https://empire-press.com/category/special/voices/clearskies/" title="Column written by Empire Press correspondent James Russell">Jim Russell</a>
</li>
	<li class="cat-item cat-item-242"><a href="https://empire-press.com/category/special/voices/letters-to-the-editor/" title="Opinions and comments from Empire Press readers">Letters to the Editor</a>
</li>
	<li class="cat-item cat-item-358"><a href="https://empire-press.com/category/special/voices/rep-dan-newhouse/" title="Column written by Rep. Dan Newhouse, a representative in the 4th Congressional District of Washington.">Rep. Dan Newhouse</a>
</li>
	<li class="cat-item cat-item-371"><a href="https://empire-press.com/category/special/voices/column-by-ken-neher/" >Senior Moments</a>
</li>
	</ul>
</li>
	<li class="cat-item cat-item-350"><a href="https://empire-press.com/category/special/waterville-days/" title="Stories about Waterville&#039;s annual community celebration">Waterville Days</a>
</li>
	<li class="cat-item cat-item-351"><a href="https://empire-press.com/category/special/wings-n-wheels/" title="Stories about East Wenatchee&#039;s annual festival">Wings &#039;n Wheels</a>
</li>
	<li class="cat-item cat-item-352"><a href="https://empire-press.com/category/special/wings-n-wishes/" title="Stories about East Wenatchee&#039;s annual festival">Wings &#039;n Wishes</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-181"><a href="https://empire-press.com/category/sports/" title="Prep and recreational sports from around Douglas County">Sports</a>
<ul class='children'>
	<li class="cat-item cat-item-308"><a href="https://empire-press.com/category/sports/baseballsoftball/" title="Prep baseball/softball stories from throughout Douglas County schools">Prep Baseball/Softball</a>
</li>
	<li class="cat-item cat-item-223"><a href="https://empire-press.com/category/sports/basketball-sports/" title="Prep basketball stories from throughout Douglas County schools">Prep Basketball</a>
</li>
	<li class="cat-item cat-item-224"><a href="https://empire-press.com/category/sports/football/" title="Prep football stories from throughout Douglas County schools">Prep Football</a>
</li>
	<li class="cat-item cat-item-311"><a href="https://empire-press.com/category/sports/track/" title="Prep track and field stories from throughout Douglas County schools">Prep Track</a>
</li>
	<li class="cat-item cat-item-225"><a href="https://empire-press.com/category/sports/volleyball/" title="Prep and junior high volleyball stories from throughout Douglas County schools">Prep/Jr. High Volleyball</a>
</li>
	<li class="cat-item cat-item-355"><a href="https://empire-press.com/category/sports/soccer/" title="Recreational soccer stories from throughout Douglas County">Soccer</a>
</li>
	<li class="cat-item cat-item-356"><a href="https://empire-press.com/category/sports/swimming/" title="Waterville swim team stories">Swimming</a>
</li>
</ul>
</li>
					
            </ul> <!-- end ul.nav -->
                
                <br class="clear" />
        <span class="nav_bottom"></span>
    </div><!-- #navwrap --> 	<div id="content">
    	<div class="content_wrap">
            <div class="content_wrap">
            	<div id="posts">
                    <div id="breadcrumbs">
                        			<a href="https://empire-press.com">Home</a> <span class="separate">&raquo;</span>
			
							<a href="https://empire-press.com/category/news/">All Content </a><span class="separate">&raquo;</span> Bacon goes way beyond mealtime			                    </div>
					                    
                    <div class="post">
		
	<div class="text no_thumb">
		<h2>Bacon goes way beyond mealtime</h2>
		<span class="postinfo">
			<span class="line"></span>
			Posted  by <a href="https://empire-press.com/author/admin/" title="Posts by Empire Press" rel="author">Empire Press</a> on Jan 24, 2019 in <a href="https://empire-press.com/category/news/" rel="category tag">All Content</a>, <a href="https://empire-press.com/category/special/voices/jill-pertler/" rel="category tag">Jill Pertler</a>, <a href="https://empire-press.com/category/special/voices/" rel="category tag">Voices</a> | <span>Comments Off<span class="screen-reader-text"> on Bacon goes way beyond mealtime</span></span>			<span class="line"></span>
		</span>
		</div>
			<p><strong>By Jill Pertler</strong><br />
<em>Slices of Life</em></p>
<p>There’s a saying: “Everything’s better with bacon.” And it’s true. Bacon is greasy and crunchy. It’s chewy and salty. It’s delectable and balanced. Bacon is akin to nature’s perfect food.</p>
<p>I’d never contemplated the idea of improving bacon. I don’t think many people have. Bacon is great flying solo or combined with any number of foods — both savory and sweet, from the traditional breakfast fodder to sprinkled on a luncheon salad or draped around a dinner steak. You can even dip it in chocolate for a flavor combination that’s just about beyond this world.</p>
<p>When God created bacon it was a good day.</p>
<p>So making bacon better? It should be impossible, or nearly so. At least that’s what I thought.</p>
<p>Then, last weekend, I made bacon.</p>
<p>And I was left with the dilemma most baconistas encounter: What to do with the inevitable grease?</p>
<p>Since the beginning of time, I’ve been using heat proof containers — empty soup cans, milk cartons and pickle jars — to dispose of the grease before placing it in the garbage. You aren’t supposed to wash that bad boy down the sink, unless you want to clog your sink. (Reference my plumbing column from November 2018 for my views on that unneeded adventure.)</p>
<p>Anyhow, last Sunday Funday it was just the two of us — me and the grease. I looked around the kitchen for an empty can or otherwise suitable vessel for discarding purposes. Seeing none, I hit upon my Eureka moment.</p>
<p>Quick sidebar here: I’ve recently taken to making candles. As I scanned my kitchen for a suitable place to get rid of the bacon grease, I spotted an empty candle jar waiting for its wax. I knew exactly what I was going to do and where I’d pour my bacon grease.</p>
<p>You’re right in guessing the candle jar. Yep. I made myself a little, albeit delectable, bacon grease candle. It hardened up nicely — not as hard as a regular candle, but hey, on previous occasions the bacon grease would have been garbage. I call that nothing short of magic.</p>
<p>I let the candle cure for a few days before lighting the wick. It burned nicely. It didn’t smell like bacon, but I never claimed this is a perfect world.</p>
<p>I suppose this exposes my inner weirdness. Who makes a candle out of bacon grease? Someone not wanting to clog her sink or add unneeded garbage into her can. Someone who makes something out of nothing. Someone who sees the candle jar as half full. Someone who thinks outside the box in ways that take bacon from a great addition to breakfast to a multi-tasking two-fer.</p>
<p>Bacon — it’s not just for breakfast (or lunch or dinner or dessert) anymore! It’s an accessory to your tablescape! It’s a candle for goodness sake! That is a wow in my world. (Again, inner weirdness but when you’re going for broke you might as well go all the way.)</p>
<p>I could go on and on, but I probably already have.</p>
<p>I’ve since made more bacon candles. What can I say? My family likes bacon. It’s a Sunday treat. Not to mention an ingredient for candles. I’ll take a two-fer product any day of the week. But I’m not done. My bacon has been elevated beyond even that. It’s the topic of this column. That, my friends, brings it to the trifecta level of a three-fer.</p>
<p>Mic drop.</p>
<p>&nbsp;</p>
<p><em>Jill Pertler is an award-winning syndicated columnist, published playwright, author and member of the National Society of Newspaper Columnists. Don’t miss a slice; follow the Slices of Life page on Facebook.</em></p>
		<br class="clear" />
						</div><!-- .post -->                      
				<!-- You can start editing here. -->

<div id="comment-wrap">

   <div id="comment-section" class="nocomments">
               <!-- If comments are closed. -->
            <div id="respond">
               
            </div> <!-- end respond div -->
         </div>

</div>                </div><!-- #posts -->  
				<div id="sidebar">
	
	<div class="widget"><h3>On The Web</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://www.facebook.com/pages/Douglas-County-Empire-Press/182761138402790?ref=mf" target="_blank"><img src="https://empire-press.com/wp-content/uploads/2008/10/Picture-2.png"  alt="Check us out on Facebook"  /></a></li>
<li><a href="http://twitter.com/#!/DCEmpirePress" target="_blank"><img src="https://empire-press.com/wp-content/uploads/2008/10/Picture-1.png"  alt="Follow us on Twitter!"  /></a></li>
<li><a href="http://www.pangbornairport.com/index.php?option=com_content&#038;view=article&#038;id=53&#038;Itemid=102" target="_blank"><img src="https://empire-press.com/wp-content/uploads/2010/12/Picture-2.png"  alt="Webcam at Pangborn Airport"  /></a></li>

	</ul>
</div> <!-- end .widget -->
		
</div> <!-- end #sidebar -->            </div><!-- .content_wrap --> 
        </div><!-- .content_wrap --> 
    </div><!-- #content --> 
</div><!-- .wrapper --> 


<br class="clear" />
<div id="footer">
	Designed by  <a href="http://www.elegantthemes.com" title="Elegant Themes">Elegant Themes</a> | Powered by  <a href="http://www.wordpress.org">Wordpress</a>
</div>
<script src="https://empire-press.com/wp-content/themes/SimplePress/js/colaborate_thin.js" type="text/javascript"></script> 
<script type="text/javascript"> 
//<![CDATA[
	jQuery.noConflict();
	
	Cufon.replace('h1')('h2',{textShadow:'1px 1px 0px #fff'})('h3',{textShadow:'1px 1px 0px #fff'})('#quote div span',{textShadow:'1px 1px 0px #fff'})('#blurbs div span.titles')('h5')('.hover span',{textShadow:'1px 1px 0px #fff'})('.fn',{textShadow:'1px 1px 0px #fff'});
	
	jQuery('ul.superfish').superfish({ 
		delay:       200,                            // one second delay on mouseout 
		animation:   {'marginLeft':'0px',opacity:'show'},  // fade-in and slide-down animation 
		speed:       'fast',                          // faster animation speed
		onBeforeShow: function(){ this.css('marginLeft','20px'); }, 			
		autoArrows:  true,                           // disable generation of arrow mark-up 
		dropShadows: false                            // disable drop shadows 
	});
	
		
	jQuery("a.lightbox").fancybox({
		'overlayShow'			: false,
		'zoomSpeedIn'			: 600,
		'zoomSpeedOut'			: 500,
		'easingIn'				: 'easeOutBack',
		'easingOut'				: 'easeInBack'
	});
	
	jQuery('.gallery_item .thumb').hover(function() {
		jQuery(this).children('.readmore').animate({opacity:'show', 'top':'170px'}, "fast");
	}, function() {
		jQuery(this).children('.readmore').animate({opacity:'hide', 'top':'148px'}, "fast");
	});
	
	var pagemenuwidth = jQuery("ul.nav").width();
	var pagemleft = Math.round((960 - pagemenuwidth) / 2);
	jQuery("ul.nav").css('padding-left',pagemleft);

	
	jQuery('div#navwrap ul.nav li a').hover(function() {
		jQuery(this).animate({opacity: .4}, "fast");
	}, function() {
		jQuery(this).animate({opacity: 1}, "fast");
	});
	
	jQuery('img#logo').hover(function() {
		jQuery(this).animate({opacity: .6}, "fast");
	}, function() {
		jQuery(this).animate({opacity: 1}, "fast");
	});
	
	jQuery('.thumb div .image').hover(function() {
		jQuery(this).animate({opacity: .8}, "fast");
	}, function() {
		jQuery(this).animate({opacity: 1}, "fast");
	});

		Cufon.now();
//]]>	
</script> <script type='text/javascript' src='https://empire-press.com/wp-includes/js/comment-reply.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://empire-press.com/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>
	
</body>
</html>


